Open Source RDBMS - Seamless, Scalable, Stable and Free

한국어 | Login |Register

CUBRID PHP API Build Guide


Build CUBRID PHP Library on Linux

In this section, we will introduce two ways of building PHP Library for CUBRID on Linux:

  1. Build CUBRID PHP Library together with original PHP source code;
  2. Build CUBRID PHP Library individually.

Build CUBRID PHP Library on Mac OS X

There are two ways to compile PHP Library for CUBRID on Mac.

  1. Build CUBRID PHP Driver on Mac OS X through PECL using CCI Driver
  2. Build CUBRID PHP Driver on Mac OS X using CCI Driver - compile the source code
  3. Build CUBRID PHP Driver for XAMPP on Mac OS X using CCI Driver

Build CUBRID PHP Library on Windows

In this section, we will introduce two ways of building PHP Library for CUBRID:

  1. Build CUBRID PHP Library with VC9 for PHP 5.3;
  2. Build CUBRID PHP Library with VC6 for PHP5.3/5.2
  3. CUBRID PHP Driver Build Guide for Windows x64

Which version do I choose?(from windows.php.net)

If you are using PHP with Apache 1 or Apache 2 from apache.org you need to use the VC6 version of PHP;
If you are using PHP with IIS you should use the VC9 versions of PHP;

VC6 Versions are compiled with the legacy Visual Studio 6 compiler;
VC9 Versions are compiled with the Visual Studio 2008 compiler and have improvements in performance and stability.
The VC9 versions require you to have the Microsoft 2008 C++ Runtime (x86) or the Microsoft 2008 C++ Runtime (x64) installed.

Do NOT use VC9 version with apache.org binaries.

comments powered by Disqus
Page info
viewed 6284 times
translations en
Author
posted 3 years ago by
hellohuizhang
Contributors
updated 2 years ago by
View revisions
Share this article