Open Source RDBMS - Seamless, Scalable, Stable and Free

한국어 | Login |Register


0
(click on this box to dismiss)

cub_master: Cannot bind local address... aborting.... Permission denied

[cub_user@71 conf]$ cubrid service start
@ cubrid master start
cub_master: Cannot bind local address... aborting.... Permission denied
++ cubrid master start: fail
@ cubrid broker start
++ cubrid broker start: success
@ cubrid manager server start
++ cubrid manager server start: success

 

 

I encountered the error message saying "Cannot bind local address... aborting.... Permission denied" when runnuing master process. What can I do?



link comment (0)
asked 11 months ago
cottonspan
61
117 Answers
0

Try changing MASTER_SHM_ID from conf/cubrid_broker.conf. Most probably there is another instance of CUBRID running on the machine so you may have to change broker ports too (BROKER_PORT for both broker entries).

link comment (0)
answered 11 months ago
rimio
1
0

When running master process in CUBRID, it checks IP and hostname in /etc/hosts file, however when your ip address is invalid or unmatched with hostname, the master process failed to run.

 

In the CUBRID 8.4.x or old versios, there was no error message left however from 9.1 version it gives out detailed error messages such as

In server.err file:

Time: 04/10/12 17:49:45.030 - ERROR *** file ../../src/connection/tcp.c, line 121 ERROR CODE = -353 Tran = 0, CLIENT = (unknown):(unknown)(-1), EID = 1 Cannot make connection to master server on host "NC-VM-PL-DEV-32".... Connection timed out

Or

Time: 04/11/12 13:36:14.786 - ERROR *** file ../../src/connection/tcp.c, line 121 ERROR CODE = -353 Tran = 0, CLIENT = (unknown) :(unknown)(-1), EID = 1 30 Cannot make connection to master server by host "NC-VM-PL-DEV-32".... Connection refused

Please check your /etc/hosts if everything is correctly set and rerun cubrid service.

link comment (0)
answered 11 months ago
cottonspan
61
0

You can also doubt if a permission is given onto /tmp directory.
CUBRID master process creates a socket in /tmp directory however without a permission on this, the same error may occur.

Use the following command. You can find out master port in the parameter, cubrid_port_id in $CUBRID/conf/cubrid.conf

su – root
chmod –R 777 /tmp

link comment (0)
answered 10 months ago
cottonspan
61




You are either using a very old browser or a browser that is not supported.
In order to browse cubrid.org you need to have one of the following browsers:



Internet Explorer: Mozilla Firefox: Google Chrome: