Open Source RDBMS - Seamless, Scalable, Stable and Free

한국어 | Login |Register

author
message
[Level:0]amichelin

Post subject: Dll error connecting to Cubrid 8.4

registered: 07/31/2011

IP: *.107.1.68

views: 6

Hi : I am new to python and to Cubrig too. I am tring to test python 3.2 with Cubrid 8.4, but with this error : Traceback (most recent call last):  File "cubridt.py", line 1, in <module>    import CUBRIDdb  File "D:\Python32\lib\CUBRIDdb\__init__.py", line 9, in <module>    import _cubrid ImportError: DLL load failed: Não foi possível encontrar o módulo especificado. Instalation: I download the cubrid40-python31-x86.zip And folow the instruction :"Copy cubrid.pyd and cubriddb.py files to the Lib folder where your Python has been installed. By default it is C:\Program Files\Python\Lib\. This is the place where all other third-party libraries are located."Details, i have not this files in the zip. I  have:_cubrid_exceptions.py_cubrid.pydAnd a folder named CUBRIDdbI copy this into my python instaltion: D:\Python32\LibWhat is the problem?I loose some steps?I have to configure some others files?Alejandro M.S.

Quote
[Level:3]hellohuizhang

# Post subject:Re: Dll error connecting to Cubrid 8.4

profile

registered: 05/16/2011

IP: *.249.143.193

Hi, your python version was 3.2 but you downloaded cubrid40-python21-x86.zip, they are mismatched. You can download the source code and unpack it, then open the cmd console, enter the directory where you have unpacked the source code, input the command "python setup.py install". It will setup the CUBRID python driver for you automatically. Hope this will help you.

Quote
amichelin

# Post subject:Re: Dll error connecting to Cubrid 8.4

registered:

IP: *.22.213.160

Quote

Hi, your python version was 3.2 but you downloaded cubrid40-python21-x86.zip, they are mismatched. You can download the source code and unpack it, then open the cmd console, enter the directory where you have unpacked the source code, input the command "python setup.py install". It will setup the CUBRID python driver for youautomatically. Hope this will help you.


[CODE]

I dowload the source and make python setup.py install.

Give me this error :

running build_ext
building '_cubrid' extension
error: Unable to find vcvarsall.bat

C compiler missing?


Delete Modify Quote
amichelin

# Post subject:Re: Dll error connecting to Cubrid 8.4

registered:

IP: *.22.213.160

Quote
Quote

Hi, your python version was 3.2 but you downloaded cubrid40-python21-x86.zip, they are mismatched. You can download the source code and unpack it, then open the cmd console, enter the directory where you have unpacked the source code, input the command "python setup.py install". It will setup the CUBRID python driver for you�automatically. Hope this will help you.


[CODE]

I dowload the source and make python setup.py install.

Give me this error :

running build_ext
building '_cubrid' extension
error: Unable to find vcvarsall.bat

C compiler missing?



Is the compiler missing.

I instaled the VC8 Express and the installation  is oknow.


Now i am trying the python with the cubrid database.

Thanks alot hellohuizhang

Delete Modify Quote




You are either using a very old browser or a browser that is not supported.
In order to browse cubrid.org you need to have one of the following browsers:



Internet Explorer: Mozilla Firefox: Google Chrome: