Open Source RDBMS - Seamless, Scalable, Stable and Free

한국어 | Login |Register

nGrinder 3.2 Release Note


nGrinder is almost approaching to the ultimate performance testing solution. We believe nGrinder 3.2 is the most developer friendly performance testing tool ever.

  • If you want to see more generic product info, please visit http://nhnopensource.org/ngrinder  

1. Release Info

  • Version : 3.2
  • Release Date : 2013.05.28

2. Changes

outline

  • We support not only Jython as a script language but also JUnit styled Groovy and Groovy Maven Project from 3.2. It is the amazing approach in which you can easily pre-run and debug the test in your IDE such as eclipse connecting to nGrinder subversion repository.
  • We support more vusers per agent by calibrating agent's JVM options. 
    • nGrinder 3.2 supports 4000 vuser(8 times more than before) per agent when you use Groovy and 4GRam agents.
    • Delete ${NGRINDER_HOME}/process_and_thread_policy.js to apply new process and thread policy in prior to ngrinder 3.2 installation. 
    • See the our test result
  • Now agent machines are rarely crashed by memory swapping. nGrinder controller stops the test which uses more than 97% memory of agents by force.  
  • IE10 is now partially supported. We added IE9 compatibility mode option to show nGrinder correctly in IE10.
    • We will continue to completely fix this by 3.2.1 
  • Graph fluctuation by nGrinder internal processing overhead is reduced. Now you can see the more stable graph.
  • The nGrinder usage is reported to our Google analytics everyday. We only collect the controller IP and the count of performance test run the last day.
    • If you don't like it, please turn it off by setting usage.report=false in system.conf
  • A user can run agents with the more detailed memory options by providing grinder.memory.permsize=Value and grinder.memory.maxpermsize=Value in the unit of mega in grinder.properties file as same folder of the selected script.
  • SVN user can enjoy the user switching feature as well just like you do in the browser.
  • And.. several minor UI enhancements.

Details

3. OS, DBMS supports

  • Linux, Windows, Mac OSX is supported.
  • Supports CUBRID, H2 as DB. The default DBMS is H2.

4. Requirements

  • Be required over Oracle JDK 1.6 version.
  • Tomcat 6.X later

5. Downloads

6. References


comments powered by Disqus
Page info
viewed 1365 times
translations en
Author
posted last year by
junoyoon
Contributors
updated last year by
View revisions
Share this article