Open Source RDBMS - Seamless, Scalable, Stable and Free

한국어 | Login |Register

Installing CUBRID PDO Driver using PECL


If PECL packager is installed in your system, the installation of CUBRID PDO Driver is straightforward. PECL will download and compile the library for you.

Requirements

To install the PDO Driver using PECL, you need to have CUBRID Database installed in your system since PDO Driver is dependent on CUBRID CCI API.

Apart from PHP, the script also needs g++ to be installed:

sudo apt-get install g++

Installation

Type the following command to install the latest version of CUBRID PDO Driver.

sudo pecl install pdo_cubrid

If you need older version of the driver, you can indicate its exact version like:

sudo pecl install pdo_cubrid-8.3.1.0003

During the installation you will be prompted to enter "CUBRID base install dir [autodetect] :". Just to make sure your installation goes smoothly, enter the full path to the directory where you have installed CUBRID. Ex: if CUBRID was installed at /home/cubridtest/CUBRID, then enter /home/cubridtest/CUBRID.

a) If you have Centos 6.0 and above, Fedora 15 and above, or Ubuntu 13.04 and above, create a file named pdo_cubrid.ini in /etc/php5/conf.d/ or /etc/php.d (check where in your system other .ini files are located).

b) Otherwise, edit the php.ini (default location: /etc/php5/apache2/php.ini or /etc/php.ini).

Then in the above .ini file add the following line:

extension=pdo_cubrid.so

To apply the changes, restart your Web Server.

What If I don't have PECL installed?

What's Next?

comments powered by Disqus
Page info
viewed 4027 times
translations en
Author
posted 2 years ago by
CUBRID
Contributors
updated last year by
View revisions
Share this article